`
chriszeng87
  • 浏览: 718132 次
  • 性别: Icon_minigender_1
  • 来自: 北京
社区版块
存档分类
最新评论

HDU_1087_Super Jumping! Jumping! Jumping!

阅读更多

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the maximum according to rules, and one line one case.
 

 

Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

 

Sample Output
4 10 3
 
参考了基德KID.1412的解法 http://972169909-qq-com.iteye.com/blog/1068856
不过我认为它的解法有些问题,
我的解法:
#include <iostream.h>
#include <stdlib.h>

int main() {
	int n,i,j;
	
	cin>>n; //输入数组的大小

	int* array = (int *)malloc(n*sizeof(int));
	int* maxA = (int *)malloc(n*sizeof(int));

	
	for(i=0; i<n; i++) {
		cin>>array[i];
		maxA[i] = array[i];
	}

	int maxSum = array[0];
	int k=0;
	for(i=0; i<n; i++) {
		k = i; //用来保存上一个最大值的位置
		for(j=i+1; j<n; j++) { 
		//求以array[i]开始的序列的最大值
			if(array[j] > array[k]) {//当前最大值
				maxA[i] += array[j];
				k = j;
				if( maxA[i] > maxSum)//overall maximun
					maxSum = maxA[i];
			}
			
		}
	}

	cout<<"The result is: "<<maxSum<<endl;

	return 0;
}
 
   欢迎批评指正

   ps:怎么把输入和输出的格式弄成题目要求的那样呢?

   while(cin >> n && n)
  {
  }

 

 

0
0
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics